We're updating the issue view to help you get more done.Learn more

Ant Design (antd) requires React 16, but we only have React 15

This yarn warning indicates some potentially serious technical debt:

1 [ERROR] warning " > antd@3.4.0" has incorrect peer dependency "react@>=16.0.0". [ERROR] warning " > antd@3.4.0" has incorrect peer dependency "react-dom@>=16.0.0". [ERROR] warning "antd > rc-editor-mention@1.1.6" has unmet peer dependency "immutable@^3.7.4".

(from https://github.com/zanata/zanata-platform/pull/773)

This means that any antd components which actually require React 16 changes will not work until we upgrade React. In fact, any antd upgrade could potentially lead to existing, currently working components breaking if the new version makes more use of React 16 (especially lifecycle changes).

Status

Assignee

Earl Mark Floden

Reporter

Sean Flanigan

Labels

Tested Version/s

None

Sprint

None

Fix versions

Priority

unspecified