Fuzzy/automatic TM search not finding good/exact matches

Description

When clicking on a long entry, it is expected that TM should be automatically search using the source string. However, the TM results did not seems relevant.

Shorter string like "OK" did not suffered from this.

When the search mode is "Phrase", copy the source string, and paste it to TM search field, returned the correct result.

However, on search mode to "Fuzzy", then copy the source string, and paste it to TM search field, returned the wrong result.

Steps to reproduce:
1. Log in with https://fedora.zanata.org/
2. Go to https://fedora.zanata.org/webtrans/translate?project=accessibility-guide&iteration=master&localeId=zh-TW&locale=zh%20#view:doc;doc:Article_Info
3. Choose "Highlight matches (otherwise it is very hard to spot the TM results)
4. Click on the entry #3 (Source string: This document describes some of the hardware devices, applications, and utilities available to assist people with disabilities to use a computer with the Fedora operating system.)

Expected:
TM result should returns the "This document describes ...." as well as it's translation

Actual:
The TM result returns "_Bind targets to network interfaces This may take a moment..."

Environment

None

Activity

Show:
Sean Flanigan
October 9, 2015, 4:56 AM
Carlos Munoz
October 9, 2015, 6:45 AM

After trying the steps in the description I discovered that changing the status (to approved, or translated, maybe others?) of the translation makes it appear in the results. This tells me that maybe the string is not indexed at all hence not being found in the search.

Sean Flanigan
October 9, 2015, 7:17 AM

Resaving by changing to Fuzzy then Translated also works. Also, if you then purge the indexes and re-index, the resaved strings do get indexed.

However, it's not entirely a multi-word thing - sometimes single words like "Fedora" or "Category" are not indexed either (unless you force it by resaving).

Sean Flanigan
October 13, 2015, 4:21 AM

I think it would be good to get an early start on QA for this production bug.

Ding-Yi Chen
October 14, 2015, 8:18 AM

I have tested it with 2 production instances.

Ready for Release

Assignee

Sean Flanigan

Reporter

Ding-Yi Chen

Labels

None

Tested Version/s

None

Sprint

None

Fix versions

Affects versions

Priority

High
Configure