More convenient naming for redux action and reducer modules
In the Redux app structure, we have ended up with modules with the same name, e.g.
This can be a little inconvenient when looking them up in the IDE:
Not difficult to distinguish but enough to break flow a bit.
I propose we include the type of module in the filename to remove the ambiguity during lookup:
This would also help if we name test files as the file under test with a suffix. Much easier to groc what is broken if there is a failure in glossary-reducers.test.js than in glossary.test.js.